Skip to end of metadata
Go to start of metadata

Apesar da plataforma Cronapp ser totalmente na nuvem, nada impede que você baixe o seu projeto e continue trabalhando off-line usando o Eclipse ou outra IDE. Veremos como configurar o ambiente e o Eclipse nesse tutorial.

Pré-requisitos

Antes de começar a seguir os passos do tutorial é preciso ter certeza de que se tem um ambiente minimamente preparado para reproduzir o exemplo. Abaixo estão os requisitos principais.

Requisitos:

  1. Projeto do tipo web criado. Caso haja dúvidas de como criar esse tipo de projeto acesse o link (Criando Projeto Web);
  2. Eclipse instalado ou descompactado na máquina local. Nesse tutorial estamos usando a versão 2018-12 do Eclipse (download em https://www.eclipse.org/downloads/), porém outras versões irão funcionar da mesma forma.

Configuração do ambiente

Para configurar o seu ambiente é necessário instalar e configurar os programas abaixo. Caso tenha dúvidas de qual versão está instalada ou como instalar, acesse a documentação: Configurações para rodar projeto local e publicar.

  • Java (JVM) ver. 1.8 ou maior;
  • Java (JDK) ver. 10;
  • Maven 3.5 ou maior;
  • Configuração das variáveis de ambientes e
  • Apache Tomcat 9.

Exportar projeto .zip do cronapp

Com o seu projeto aberto no Cronapp, clique com o botão de contexto (direito) do mouse no nome do projeto e escolha a opção Exportar no menu. A janela de seleção dos formatos a serem exportados abrirá, clique no formato Zip (1) e finalize (Figura 1.1). O Cronapp compactará o projeto e logo em seguida inicializará o download na sua máquina local.

Figura 1.1 - Baixando projeto compactado do Cronapp

 

Após o download, descompacte o conteúdo para um diretório a sua escolha, usaremos esse diretório para abrir o projeto no Eclipse.

Eclipse

Após configurar o ambiente e exportar o projeto do Cronapp, vamos importar o projeto e configurar o Eclipse nos passos abaixo.

Importando projeto

Abra o Eclipse, clique com o botão de contexto (direito) do mouse dentro da aba Project Explorer e selecione Import > Import... (Figura 2.1) para abrir a janela de importação de projetos.

Figura 2.1 - Abrindo a janela de importação de projeto existente

 

Na janela Import, selecione o item Existing Maven Projects dentro do diretório Maven e avance (Figura 2.2).

Figura 2.2 - Selecionando com Maven


Na tela seguinte, informe no campo Root Directory o local onde foi descompactado o projeto do Cronapp, selecione todos os itens no campo Project e finalize em seguida (Figura 2.3).

Figura 2.3 - Finalizando importação de projeto Maven

 

Após a importação do projeto, o Eclipse começará a baixar todas as dependências do Maven usadas no projeto, esse processo poderá levar alguns minutos para concluir (Figura 2.4).

Figura 2.4 - Baixando as dependências do Maven

Configurações do Eclipse

Nesse passo vamos cadastrar os caminhos dos diretórios do JRE e do Tomcat no Eclipse, necessários para executar a aplicação como informado no tópico de configurações do ambiente.

No menu de sistemas do Eclipse, clique em Windows > Preferences para abrir a janela de Preferencias (Figura 2.5). Na árvore de configurações lateral, expanda o item Java e clique em Installed JREs (1). Na área de seleção do JRE, clique no botão Add.... (2) para abrir a janela Add JRE, selecione a opção Standard VM e clique em Next para ir para próxima tela, JRE Definition, clique no botão Directory... (3), selecione o diretório onde está o JDK na sua máquina e finalize em seguida.

Figura 2.5 - Apontando para o diretório do JRE

 

Vamos configurar o Tomcat na mesma janela de Preferencias do Eclipse. Expanda o item Server na árvore de configurações lateral e clique em Runtime Environments (1) abrindo as configurações na direita. Clique no botão Add... (2), no campo Select the type of runtime environment selecione Apache Tomcat v9.0 e avance para próxima tela, como na figura abaixo. 

Figura 2.6 - Seleção da versão do Tomcat instalado

 

No campo Tomcat installation diretory informe o caminho onde foi instalado o Tomcat na sua máquina (1) e informe o JRE (2) configurado no passo acima (Figura 2.6).

Figura 2.5 - Apontando o diretório do Tomcat

 

Após realizar essas duas configurações, clique em Apply and Close na janela de Preferencias do Eclipse.

Configuração do servidor

Nesse passo iremos apontar e configurar o servidor no Eclipse.

Na aba Servers inferior (caso não esteja aparecendo adicione no menu de sistema Window > Show View > Servers), clique em "No servers are available..." (1) para abrir a janela New Server, selecione Apache Tomcat v9.0 (2) no campo Select the server type e verifique se no campo Server runtime environment está selecionada a opção Apache Tomcat v9.0. Avance em seguida (Figura 2.6).

Figura 2.6 - Selecionando o Tomcat configurado anteriormente

 

Na tela seguinte, mova os recursos do projeto para direita e finalize em seguida (Figura 2.7).

Figura 2.7 - Adicionando recursos configurados

 

Agora a aba Servers exibirá o servidor que acabamos de configurar, dê um clique duplo (1) para exibir suas configurações. Na área Timeouts aumente o tempo limite de inicio para 300 segundos (2) e verifique que as configurações de portas podem ser alteradas na área Ports (3) (Figura 2.8)

Importante

Caso o Tomcat já esteja rodando em paralelo ao Eclipse e usando as mesmas portas, não será possível iniciar o servidor no Eclipse. Pare o Tomcat na máquina local ou altere o valor das portas.


Figura 2.8 - Aumentando o tempo limite de inicio e verificando as portas

 

Ainda na mesma tela, desabilite a opção Modules auto reload by default na área Server Options (Figura 2.9).

Figura 2.9 - Desabilitando o carregamento automático dos módulos

 

Alterne da aba Overview para Modules (1), selecione o modulo web cadastrado, clique no botão Edit... (2) e na janela de edição desmarque a opção Auto reloading enabled. Clique em OK e salve em seguida. (Figura 2.10)

Figura 2.10 - Desabilitando o recarregamento automático do módulo

Configurações do projeto

Os passos abaixo não são necessários para rodar ou continuar desenvolvendo o seu projeto no Eclipse, apenas facilita a abertura do projeto no navegador, simplificando a URL e retira as notificações de JavaScript do projeto.

No menu de sistema, acesse Project > Properties para abrir a janela de propriedades do Projeto. Na árvore de configurações lateral clique em Web Project Settings (1) e substitua o valor do campo Context root para "/" (2) (Figura 3.1).

Figura 3.1 - Redução da URL do projeto

 

Em algumas situações quando importamos o projeto no Eclipse, o mesmo notifica erro na validação de JavaScript (1), essas notificações podem ser ocultadas na janela de propriedades do projeto através do item Validation, desabilitando as colunas Manual e Build da opção JavaScript Validation, como exibido na Figura 3.2.

Figura 3.2 - Desabilitando a validação JavaScript

Rodar o servidor e abrir o projeto

Após configurar os passos acima, rode o servidor clicando em Start the Server na aba Servers (1), aguarde o servidor concluir a inicialização, abra um navegador e digite o endereço "localhost:8080" (2), como na Figura 4.1.

Figura 4.1 - Rodando o servidor e abrindo o projeto Cronapp no Eclipse

 

Nesta Página

 

 

  • No labels